Subject: Re: PyCrypto license clarification

From: M Moraes <[email-masked]>
Date: Mon, 20 Apr 2009 16:25:32 -0700 (PDT)

Hi Dwayne.

Sure, the new license sounds fine for all my contributions to PyCrypto, and thanks for taking it on.  My apologies for not responding to your previous e-mail.

Regards,
Mark.

--- On Sat, 4/18/09, Dwayne C. Litzenberger <[email-masked]> wrote:

> From: Dwayne C. Litzenberger <[email-masked]>
> Subject: PyCrypto license clarification
> To: "Mark Moraes" <[email-masked]>
> Date: Saturday, April 18, 2009, 9:14 AM
> Hi Mark,
> 
> I am the new maintainer of the Python Cryptography Toolkit,
> and I am
> working on a new release at http://www.pycrypto.org/.
> 
> People often ask me what license PyCrypto is covered by, if
> it's
> GPL-compatible, etc.  Right now, I'm not really sure
> what to tell them.
> The text in the current LICENSE file (quoted below) is not
> entirely clear
> on the point of whether distributing modified versions is
> allowed.  (It
> says "distribute and use", but not "modify".)
> 
>      
> ===================================================================
>       Distribute and use freely; there are
> no restrictions on further
>       dissemination and usage except those
> imposed by the laws of your
>       country of residence.  This
> software is provided "as is" without
>       warranty of fitness for use or
> suitability for any purpose, express
>       or implied. Use at your own risk or
> not at all.
>      
> ===================================================================
> 
>       Incorporating the code into commercial
> products is permitted; you do
>       not have to make source available or
> contribute your changes back
>       (though that would be nice).
> 
>       --amk       
>                
>                
>             (www.amk.ca)
> 
> For the next PyCrypto release, I would like to take steps
> to move toward a
> clearer licensing regime.  I am asking as many
> copyright holders as I can
> find if I can release PyCrypto under something clearer and
> more standard.
> Below, I have quoted a public domain dedication that was
> recommended in
> _Intellectual Property and Open Source: A Practical Guide
> to Protecting
> Code_, by Van Lindberg.  I have already contacted A.
> M. Kuchling, Robey
> Pointer, Wim Lewis, Jeethu Rao, and Barry Warsaw, and they
> have all
> approved the following dedication for their contributions.
> 
> I understand that you have made contributions to
> PyCrypto.  May I, on your
> behalf, dedicate to the public domain all your
> contributions to PyCrypto,
> with the following notice?
> 
>      
> =======================================================================
>       The contents of this file are
> dedicated to the public domain.  To the
>       extent that dedication to the public
> domain is not available, everyone
>       is granted a worldwide, perpetual,
> royalty-free, non-exclusive license
>       to exercise all rights associated with
> the contents of this file for
>       any purpose whatsoever.  No
> rights are reserved.
>      
> =======================================================================
> 
> Regards,
>    - Dwayne
> 
> -- Dwayne C. Litzenberger <[email-masked]>
>    Key-signing key   - 19E1
> 1FE8 B3CF F273 ED17  4A24 928C EC13 39C2 5CF7
>

---

From: "Dwayne C. Litzenberger" <[email-masked]>
Date: Mon, 20 Apr 2009 20:01:37 -0400

Thanks a lot, and don't worry about not responding to previous emails.  I 
do that too much myself. :)

-- 
Dwayne C. Litzenberger <[email-masked]>
  Key-signing key   - 19E1 1FE8 B3CF F273 ED17  4A24 928C EC13 39C2 5CF7
  Annual key (2008) - 4B2A FD82 FC7D 9E38 38D9  179F 1C11 B877 E780 4B45